I have been looking for such a library and didn't find any, do you guys know if such a library exists? If not, why do you think there isn't one in PHP? You can find those in other web languages like Python...
The PHP binary must link with the same, or more recent, major version of Oracle libraries as it was configured with. For example, if you build OCI8 with Oracle 11.2 libraries, then PHP should also be...